Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've been trying to set up mod_rewrite on a newish, fairly clean install of Apache 2, on Ubuntu 8.04. However, whenever I test the URL-to-be-redirected, I get a 404.

I ran a2enmod rewrite and a2enmod proxy; as far as I can tell, they were successful - my mods-enabled directory contains proxy.conf, proxy.load, and rewrite.load.

My vhosts file includes this:

DocumentRoot /var/www/saveplay
<Directory /var/www/saveplay>
    Options FollowSymLinks
    AllowOverride All
</Directory>

and my .htaccess file is in the relevant directory. (It's currently owned by www-data; it didn't work when it was owned by root either.) It looks like this:

Options +FollowSymLinks

RewriteEngine On

RewriteRule ^/koolaid$       https://www.kintera.org/site/c.leJNIPOvErH/b.5926197/k.4F51/Save_Play_Donation_Form/apps/ka/sd/donor.asp?source=koolaid  [R=301]

I am sure there is something desperately stupid and simple that I am missing, but my google-fu is failing me.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

If you are just redirecting everything at /koolaid to a new location couldn't you just use the following in your .htaccess?

Redirect 301 /koolaid https://www.kintera.org/site/c.leJNIPOvErH/b.5926197/k.4F51/Save_Play_Donation_Form/apps/ka/sd/donor.asp?source=koolaid
share|improve this answer
    
...Yes, yes I could. Thanks! –  bhaibel Jul 12 '10 at 21:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.