Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hi I am installing httpd-2.0.63 with the open ssl. ssl version is OpenSSL 1.0.0a

Commands are :

./configure --prefix=/usr/LBalancer2/apache --enable-so --enable-ssl --with-ssl=/usr/LBalancer2/ssl

make

But this step gives the following ERROR :

ssl_engine_init.c: In function 'ssl_init_ctx_protocol':

ssl_engine_init.c:391: warning: assignment discards qualifiers from pointer target type

ssl_engine_init.c:397: warning: assignment discards qualifiers from pointer target type

ssl_engine_init.c: In function 'ssl_init_ctx_verify':

ssl_engine_init.c:534: error: 'STACK' undeclared (first use in this function)

ssl_engine_init.c:534: error: (Each undeclared identifier is reported only once

ssl_engine_init.c:534: error: for each function it appears in.)

ssl_engine_init.c:534: error: expected expression before ')' token

ssl_engine_init.c: In function 'ssl_init_FindCAList':

ssl_engine_init.c:1109: warning: pointer type mismatch in conditional expression

make[3]: * [ssl_engine_init.lo] Error 1

make[3]: Leaving directory `/home/arosys/Softwares/httpd-2.0.63/modules/ssl'

make[2]: * [all-recursive] Error 1

make[2]: Leaving directory `/home/arosys/Softwares/httpd-2.0.63/modules/ssl'

make[1]: * [all-recursive] Error 1

make[1]: Leaving directory `/home/arosys/Softwares/httpd-2.0.63/modules'

make: * [all-recursive] Error 1

I have no idea what to do.

Any one can help.

Thanks

share|improve this question
    
Any reason you're still using Apache httpd 2.0 instead of the 2.2 series? –  joschi Jul 13 '10 at 10:27
    
No not any reason.the document that I had, gave the url to download apache2. –  sjain Jul 13 '10 at 10:32

2 Answers 2

Apache 2.0/2.2 is not compatible with OpenSSL 1.0.0, see bug reports:

You should use OpenSSL 0.9.8.

When it's compiled you will have a module called: mod_ssl.so

You can use ldd to check which library of ssl is used:

$ ldd mod_ssl.so
linux-gate.so.1 =>  (0xb7f2a000)
libssl.so.0.9.8 => /usr/lib/i686/cmov/libssl.so.0.9.8 (0xb7eac000)
libcrypto.so.0.9.8 => /usr/lib/i686/cmov/libcrypto.so.0.9.8 (0xb7d59000)
libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7d3f000)
libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb7be4000)
libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb7be0000)
libz.so.1 => /usr/lib/libz.so.1 (0xb7bcb000)
/lib/ld-linux.so.2 (0xb7f2b000)

Apache.org has excellent documentation on how to configure your webserver: http://httpd.apache.org/docs/2.1/ssl/ssl_howto.html

share|improve this answer
    
Thank You. I will move to OpenSSL 0.9.8 –  sjain Jul 13 '10 at 10:59
    
I installed OpenSSL 0.9.8. It installed. How can I make sure that Apache is installed with OpenSSL. –  sjain Jul 13 '10 at 13:00
    
this time also I used the same configure command but moved from apache2.0 to apache2.2 –  sjain Jul 13 '10 at 13:02
    
The options you used before: --enable-ssl --with-ssl=/the/location/of/openssl-0.9.8 should do just that. –  basvdlei Jul 13 '10 at 13:30
    
Isnt any command or file's presence that can make sure? one more thing how can I apply security provided by openssl.Any useful refrence? Thanks. –  sjain Jul 13 '10 at 13:59

My best guess is missing headers for openssl are you sure they exit in /usr/LBalancer2/ssl check your output of the configure command to make sure that the openssl headers are picked up.

share|improve this answer
    
sure there was no problem in configure command. –  sjain Jul 13 '10 at 10:25
    
there was problem of missing header while installing opennssl.But that was solved by googling. –  sjain Jul 13 '10 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.