Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Debian Squeeze on my computer and since then I cannot mount any Samba shares, remote or local (running Samba server on localhost). The error I get (as root) is:

cmd > ~: mount -t cifs //awakening/library4 /mnt/local1/ -o guest
mount error(1): Operation not permitted
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I can try mounting some random share (which doesn't exist) and get the same error, so it doesn't even check if the share exists on the remote side. The same share worked when I had Debian Lenny installed.

What is the problem?

share|improve this question
Anyone? On a related note, I'm missing the "umount.cifs" binary. It's actually missing from the DEB package. – Matic Jul 24 '10 at 17:13

zless /usr/share/doc/cifs-utils/NEWS.Debian.gz

cifs-utils (2:4.0-1) unstable; urgency=low

  * As of this version, the mount.cifs binary is no longer setuid due to
    upstream concerns about the audit status of this code.  As a consequence,
    users will no longer be able to run mount.cifs directly to mount shares
    unless mount points have been individually configured in /etc/fstab with
    the "user" mount option.
share|improve this answer

Looks like a permission error to me, which would explain why it's throwing the same error regardless of whether the share exists: it's never getting past authentication.

Is your machine on the domain?

share|improve this answer
No, it is not on a domain. And it worked just fine with the same share permissions on Debian Lenny. The share I'm trying to mount works from Windows client. – Matic Jul 13 '10 at 14:04

You probably need to wrap that mount command in sudo. I don't think it'll let you mount samba shares as a regular user-only as root.

share|improve this answer
I am running the command as root. I don't use sudo. – Matic Jul 14 '10 at 6:34
budde: that's what i was thinking too, because of the ">" in "cmd > ~:...." which usually indicates the shell running as non-root user – tkSimon Nov 8 '10 at 16:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.