Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to RDP to a Windows 2003 server, sometimes after I enter the login credentials, I see the background color of the desktop, but no icons, and no taskbar. Sometimes disconnecting from RDP, and then reconnecting solves it, but I don't see any issues in the Event Logs.
I know the machine is up, as it presents the login screen, and if I put a bad password, or a user name that does not have the rights to login remotely, it tells me. But when I put a good password in, it just hangs on the background.

Any Ideas on what to check?

TIA

share|improve this question
    
Have you checked the issues here support.microsoft.com/kb/555840? –  Zoredache Jul 13 '10 at 16:40
    
@Zoredache - Yes, I've tried disabling the BitMap cacheing with no success. I have not played with the MTU on the Server, but its the W2K3 default. I don't suspect the switch/router, as I can connect to other servers on the subnet. –  BillN Jul 14 '10 at 2:02
add comment

1 Answer

up vote 5 down vote accepted

I've seen this happen when you don't have a clean log off of your previous session. If you log onto the console and check the RDP connected users do you have an entry there for your user? If so kick it off the RDP session and try logging in again.

share|improve this answer
    
Yep, I've seen this when a logoff doesn't complete for whatever reason (in my experience, usually profile issues). You can safely kill the session from the RDP MMC Console. –  notpeter Jul 13 '10 at 16:58
    
There WAS a disconnected session. I killed it an will see if the problem goes away... –  BillN Jul 14 '10 at 1:59
    
Worked for me: Administrative Tools->Terminal Services Manager. –  Kev Jul 21 '10 at 14:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.