Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm installing an RPM on RedHat Enterprise Linux 5 and it fails with the following error:

error: Failed dependencies:
    rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by vspd-1/43-rsmu.i586

Which package contains rpmlib? I've tried:

yum install rpmlib //didn't exist
yum install rpm //already installed
yum install rpm-devel //not the right one

I've looked around for the answer to this question and all I've found is...
...people looking for the answer to this question!

Like on this forum and a dozen others. I've successfully installed this RPM (VSPDL) before so I know the answer exists and someone probably knows it. I just don't remember which package magically fixed the dependency.

All suggestions are appreciated,


share|improve this question

migrated from Jul 13 '10 at 22:39

This question came from our site for professional and enthusiast programmers.

Looks to me like your rpm is outdated (doesn't support lzma compression) / (or the package quite new, depending on how you look at it). – ChristopheD Jul 12 '10 at 21:17
hmm. I tried doing yum install rpm but it tells me it's already there and up to date: Package rpm- already installed and latest version. Is it lying to me? – gmale Jul 13 '10 at 10:52

I hope this helps whoever it is that favorited this question,

Finally got google to give me better results. Per this forum and this experts exchange response (scroll to the very bottom),

It's not a problem of rpm versions--it's just flat-out not supported: The RPM has been produced with LZMA payload compression which is not supported by RHEL (CentOS).

My only option is to compile what I'm trying to install, from source (which is available in a tarball) or to use a different rpm. Although the rpm I'm using says it's for "Redhat, Madriva, SuSe, Ubuntu, Gentoo," it's not actually for the Enterprise version of RedHat.

I'm going to try my luck with the RedHat 9, i386 RPM and if that doesn't work, I'll compile the source.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.