Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have windows server 2008 with IIS7.

I was having problems getting a new website to work in today...I've been troublshooting for about 2 hours now and haven't come up with anything.

Heres what is weird:

I have a working website running on IIS named "TI." It points to the directory "C:\Websites\TI\web". This website works perfectly!!!

If I:

  • copy this directory then paste it as "C:\Websites\TI\web - Copy"
  • go to IIS Manager
  • "Add Web Site"
  • then select the "web - copy" directory
  • point a new domain to it
  • fireup my browser to point to the site
  • I get: "500 - Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed."

Any ideas as to what the problem could be?

Imma 'bout gunna break this here darned keyboard over my face outta frustration.


If I change the original site ("TI") to point to the new copy of itself ("web - Copy") the website will work fine! WTF?

share|improve this question

Maybe try something that doesn't contain spaces or special characters? It worked for me once.

share|improve this answer
nope. it didn't work...but it did surface another issue....i can change the directory name without stopping the Web Site in IIS. I shouldn't be able to do that right? – David Murdoch Jul 14 '10 at 23:03
Hm, I didn't even tried it. I always stop Web Sites before changing directory names. IIS's log does say something useful releated to a file or something else? – user39810 Jul 14 '10 at 23:07

The web sites may be configured to use the same HTTP port without setting up a host header in IIS. If you check for ASP.NET errors in the event viewer you may find an error stating that IIS failed to set up the new website using those particular bindings.

If you stop the original website, then create the new one does it work?

share|improve this answer
up vote 0 down vote accepted

It ended up being a problem with windows' Permissions. Resetting them did the trick.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.