Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running a RHEL 5 (64 bit) guest on Microsoft Hyper-V.

I've always had trouble with the clock getting way ahead of itself, which I was able to solve previously by adding

divider=10 clocksource=acpi_pm

to the kernel params in /boot/grub/menu.lst and setting up ntpd.

This worked with kernel 2.6.18-194.3.1.el5 however since the security upgrade to 2.6.18-194.8.1.el5 ntp will not longer sync.

Here is the output of ntpq -pn with 2.6.18-194.3.1.el5

$ ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
+192.189.54.33   203.35.83.242    2 u    5   64  377   17.311  -51.753  63.074
*202.83.64.2     203.35.83.242    2 u    7   64  377   19.625  -104.46  27.096
+202.60.94.11    203.12.160.2     3 u   62   64  377   34.398  -121.42  26.216
 127.127.1.0     .LOCL.          10 l   11   64  377    0.000    0.000   0.001

And with 2.6.18-194.8.1.el5

$ ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 192.189.54.33   192.189.54.17    3 u   28   64   17   17.075  -9505.7 5518.42
 192.189.54.17   203.35.83.242    2 u   28   64   17   17.389  -9669.1 5596.65
 202.60.94.11    203.12.160.2     3 u   33   64   17   33.192  -142.84 9016.50
*127.127.1.0     .LOCL.          10 l   31   64   17    0.000    0.000   0.001

I'm out of ideas. I've tried a few other kernel params such as

notsc divider=10

But still the same results.

Any suggestions on what else may work?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I believe I have just found the answer. I needed to add in notsc but also keep divider=10 and clocksource=acpi_pm as well.

The entry in /boot/grub/menu.lst now looks like this and the click seems to be synch'ing again:

kernel /vmlinuz-2.6.18-194.8.1.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet notsc divider=10 clocksource=acpi_pm
share|improve this answer

Are integration services configured to set the clock? If so have you tried disabling it?

share|improve this answer
1  
Hi Chris, Yes I disabled this. Pretty much I have followed the steps in the URL below. This was working perfectly until the upgrade do the new kernel. social.technet.microsoft.com/Forums/en-US/winserverhyperv/… –  user38939 Jul 15 '10 at 5:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.