Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do i change my default phpmyadmin port to 443 or 9999? Is it possible or do I have use port 80 only? If possible, then how do I change share the same?

Apache is listening on port 9999 for sure. However, going to URL

http://<webserver>:9999/phpmyadmin/

Will give following error (with Firefox browser)

An error occurred during a connection to webserver:9999.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

Anyone has any clue what is going on?

share|improve this question

closed as off-topic by Falcon Momot, mdpc, Ward, dawud, Scott Pack Sep 30 '13 at 17:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Falcon Momot, mdpc, Ward, dawud, Scott Pack
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you concerned about security (e.g. SSL) or do you just want a different port? –  ewwhite Dec 9 '12 at 5:27
add comment

4 Answers

up vote 3 down vote accepted

edit the config.inc.php file in the phpMyAdmin directory and change the following line:

$cfg['ForceSSL'] = FALSE; // whether to force using https 
share|improve this answer
1  
thanks for quick support can tell which place i have to add this line!! –  Rajat Jul 15 '10 at 15:15
1  
Should be you in your config.inc.php file in the phpmyadmin directory wiki.phpmyadmin.net/pma/config.inc.php –  The Digital Ninja Jul 15 '10 at 15:17
1  
I don't understand how this is even related to the question. Digital Ninja: can you try to edit the question to show how this answer relates to it?!? –  Theuni Dec 9 '12 at 12:16
    
@Theuni - this triggers internal PHPMyAdmin rules that force the interface to HTTPS. Only works if you actually have HTTPS installed and configured though, but the original question is frankly so shit there's no way we would know or not. (have a look at the original edits if you want) –  Mark Henderson Dec 10 '12 at 1:11
add comment

If you want to run phpMyAdmin on a non-standard port, it should autodetect the URL and port number you've chosen in your web server configuration. Since you don't mention which web server you use, consult its documentation to see how to set up the web server to listen on a non-standard port.

If for some reason phpMyAdmin doesn't detect them correctly, you can override it by setting the PmaAbsoluteUri directive to whatever the URL should be.

(You may also combine this with the ForceSSL directive as shown in @TheDigitalNinja's answer, and any other directives you may need to use.)

For example:

$cfg['PmaAbsoluteUri'] = 'http://rajat.example.org:9999/phpMyAdmin/';
share|improve this answer
add comment

It doesn't depend on phpMyAdmin at all and it's not required to know it's absolute url.

You need to change port on webserver side.

share|improve this answer
add comment

You can't do that. Phpmyadmin is a collection of phpscripts that run at the WEB-Server. Phpmyadmin does not use ports. Web-server does. You should go to your webserver configuration and change the default port there.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.