Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 3.5 web application running fine on Windows2003 IIS6. I published same exact application to IIS7.5 (Win2008R2) on a faster box (i5,8Gram) and it is significantly slower. 5-6 sec per page vs. 1-2 sec per page. During that time the Task Mgr CPU is always under 10%. Both attach to same database on other box. Benchmark is consistent from any other client browser or machine. I have connection pool on both, compression on both. Same network subnet. Forms authentication (no SSL yet). Can you give me steps on how to troubleshoot where the delays are being inserted or settings in IIS7 that I may have overlooked. Just using defaults.

There is only 1 web site on each box. I understand the roles of an Application as defined in IIS has changed. There is no special Application defined in IIS.

share|improve this question
Are you using Integrated mode or Classic on IIS7? – Artem K. Jul 16 '10 at 5:37

5-6 sec per page vs. 1-2 sec per page. During that time the Task Mgr CPU is always under 10%.

Ok, 10% means likely one core runs full speed, the others are not busy. Taking out the obvious (crappy configuration application pool to only one core) this points towards a really bad programming issue. Attach a profiler and find out where the time is actually spent.

5-6 seconds per page is crap. Here is th ebad news, though: 1-2 seconds per page is firing level performance in 99% of the cases under low load. There is very little way a page procvessing should take more than let#s say 50... MILLISECONDS. I would be a lot more concerned wih a 1-2 sseocond time to start with - this points towards a real programming issue that was never fixed.Even on your old server your system was SLOW. Dead slow.

Start using a profiler to see where your time is spent, to start with.

Both attach to same database on other box.

Can it be your database server is overloaded? That your sql calls take 10 times as much time as they should?

share|improve this answer

Enable failed request tracing in IIS. This will help you see where you are spending your time during the call. Once configured, repro the performance problem, and then open up the generated .xml file to see the results (make sure the .xsl file is there too).

edit: I posted a bit of a step-by-step guide on stackoverflow for a different problem here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.