Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a LAN network consisting of 2 laptops where my friend's laptop is acting as a server and my laptop is acting as a client...I could detect my friend's instance i.e PC/SQLEXPRESS an d so can he....

I have created a login name and password in his laptop(i.e SQL server) and even the TCP/IP and named pipes is selected on both Laptops and the Firewall Disabled...However it's not accepting the given username and login in the SQL SERVER AUTHENTICATION...and is giving error "Connection Failed : Login 'Sujit' cannot be connected to a trusted SQL SERVER".....

please help....

share|improve this question
add comment

migrated from stackoverflow.com Jul 16 '10 at 4:46

This question came from our site for professional and enthusiast programmers.

3 Answers

Probably not the right site for this question I suspect that it'll get migrated somewhere.

On the SQL Server you are connecting to does it show the login failure in the SQL server logs? If so I think there should be an error subcode that you can google to find out the exact problem.

share|improve this answer
    
@Martin.....it's a pop up window.... –  Anonymous Jul 15 '10 at 18:43
add comment
  1. In Object Explorer: Right click Your Server and open Properties
  2. Select Security in the left pane of the properties window
  3. On the right side you will see Server Authentication
  4. Select "SQL Server and Windows Authentication Mode"
  5. Close the properties windows by clicking OK
  6. Restart your Server by right clicking your Server and choosing restart

Try login now

Edit:

Server Explorer

SQl Serve Management studio

share|improve this answer
    
@Muhammad Kashif...i could'nt find Object Explorer....my server is stored in Server Explorer....Right Clicked....But the 'Properties' option is inactive... –  Anonymous Jul 15 '10 at 18:42
    
@sujitanand Don't you have SQL Server Management Studio? Server Explorer is in Visual Studio and you can not manage your server from Server Explorer. See Two links in my edited answer. –  Kashif Jul 15 '10 at 19:27
add comment
  1. Open the SQL Server Surface Area Configuration, since this is Express, remote connections are disabled by default.

  2. Once you are in The SA Config window, click on Surface Area Config for Services and Connections.

  3. Click on Remote Connections under Database Engine

  4. Select Local and Remote Connections, and choose your type. (TCP, named pipes, or both)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.