Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Found this problem that mirrors mine exactly: http://serverfault.com/questions/125395/solved-network-issue-ubuntu-8-04-in-vmware-esx

However, VMware tools didn't fix this for me.

Pinging the box from another system on the network gives "Request timeout for icmp_seq xxx". Pinging from the Ubuntu 8.04 box itself yields the same result: no answered pings. DHCP works. The IP shows up in vSphere. VMware Tools is "OK".

Doing an ifdown eth0 followed by ifup eth0 appears to go through the motions and grab a DHCP lease.

arp -a takes a long time to run. Sometimes there are duplicate entries.

VMware tools have been installed & reinstalled.

Interesting: if I ping a different IP each time, I get 2 or 3 responses... and then ping stops responding. Actually, as I watch it... this one got 3 responses, then waited 30 seconds, then 3 more responses, 30 seconds later... 3 more responses. It's like clockwork.

share|improve this question
    
WORKAROUND: Assigning the interface a static IP made the networking problems disappear. –  nvahalik Jul 16 '10 at 15:44
    
I wouldn't say workaround as much as best practice. Is there any real reason not to do static ip's? –  The Digital Ninja Jul 16 '10 at 16:05
    
have you attempted to uninstall vmware tools completely? –  JakeRobinson Jul 31 '10 at 6:08

2 Answers 2

If you expect to be a VMware issue then stop the VM, remove the NIC from the VM, add another NIC to the VM and then boot the VM.

Check if you do not have an IP conflict. Use arping to "ping" servers and router in the same VLAN. If 2 hosts are answering, then you have an IP conflict. For the arp command return immediately (without name resolution), use arp -n in Linux.

share|improve this answer

I would recommend uninstalling vmware tools from the guest OS. I had an issue where the network drivers provided by the tools were causing packets to be malformed in some way. ICMP worked, UDP and TCP didn't.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.