Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Google Apps to send mail through my private domain. I have used WHM to set my DNS TXT record to "v=spf1 ~all" for as advised by Google.

When I send a bunch of SMTP mails, I get SPF passes to emails sent to external domains from But emails that go to get a softfail as follows:

Received-SPF: softfail ( domain of transitioning does not designate as permitted sender) client-ip=;
Authentication-Results:; spf=softfail ( domain of transitioning does not designate as permitted sender)

where is the dedicated IP for

Any idea why this is? Even though I have set the server to send SMTP through Google, it seems to just overwrite that for emails to the local domain. I have tried changing the TXT record to "v=spf1 ipv4: ~all" but get the same result.

Thanks in advance.

share|improve this question
up vote 1 down vote accepted

How long did you wait after making the change to your SPF record? What is the TXT records TTL? Based on the information you're providing you seem to have it configured correctly. DNS is cached and replicated system so you make take hours or days based on the length of the TTL.

Edit: I believe you have a typo it should be "ip4:" Check that your SPF is vaild here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.