Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to make an ubuntu development server work. All machines on the network (mac and windows) get internet and lan access but ubuntu only works on the lan.

I have two interfaces: eth0 (static) eth1 (dhcp, but virtual box bridges it to run a windows application server, wich has both lan and internet access)

my static configuration for eth0 is:

auto eth0
iface eth0 inet static

auto eth1
iface eth1 inet dhcp

and here is the ipconfig of a windows machine wich has everything working with static setup:


routes on ubuntu server:

administrador@servidor-linux:~$ route -n     U     1000   0        0 eth0       U     0      0        0 eth0       U     0      0        0 eth1         UG    100    0        0 eth1         UG    100    0        0 eth0

routes of a windows machine with everythin working:

route print
Lista de interfaces
0x1 ........................... MS TCP Loopback interface
0x2 ...78 e7 d1 f2 67 7d ...... Realtek PCIe FE Family Controller - Miniporta do
 agendador de pacotes
0x3 ...c4 17 fe 09 3a e4 ...... Adaptador de rede Broadcom 802.11b/g - Miniporta
 do agendador de pacotes
Rotas ativas:
Endereço de rede          Máscara   Ender. gateway       Interface   Custo
       25       25       25       25       1       25       1               2       1
Gateway padrão: 
Rotas persistentes:

what am i doing wrong?

share|improve this question

migrated from Jul 16 '10 at 18:05

This question came from our site for professional and enthusiast programmers.

I think that should be network broadcast but I'm no expert. – Thomas Jul 16 '10 at 17:45
It would be of interest to see your routing tables. route -n for linux, ROUTE /N PRINT (I think) for Windows. – Carl Smotricz Jul 16 '10 at 17:51
just added the routes – Victor Jul 16 '10 at 18:03
installed network manager and internet still didnt work, but when i disabled one network interface everyting goes ok. How should I do to have static ip in eth0 and openbox bridge in eth1 ? – Victor Jul 16 '10 at 18:47

1 Answer 1

Delete that route         UG    100    0        0 eth1

Anything for the internet is forwarded via eth1 instead of eth0. Also try not to use so big netmasks , except for the cases that you are an ISP :p

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.