Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was getting some to me inexplicable behavior from apt-get/aptitude on an admittedly crusty old webserver. While it was otherwise running fine, as soon as I tried a package upgrade, after a downloading a few updates it would stall completely, then my SSH session hung (and I was unable to reconnect), thus requiring a hard restart.

First, I switched to a different package source in /etc/apt/sources.list, but still got the same behavior. At this point I was assuming the NIC was dying in some weird way... but as soon as I changed the package source to use FTP instead of HTTP, everything worked fine, and I was able to upgrade.

For now I'm not too concerned since I have an easy work around, but it implies that there's something very weird with my network setup, since it seems to be protocol (or port?) specific. I didn't think any of my NAT setup would affect outbound traffic, but I could be crazy. Any ideas what I should try to look for?

share|improve this question

1 Answer 1

Are you maybe on an ISP connection with limited download bandwidth or throttling or a throughput limit on it? What happens if you use wget instead of apt-get? Can you monitor the traffic through tcpdump or iptraf in a second ssh session (up to the point where it dies?

share|improve this answer
    
It's a Comcast home connection, so I wouldn't put anything past them. I've since moved this server to Rackspace hosting, so I never found the problem. –  UltraNurd Dec 16 '11 at 18:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.