Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had just build subversion repository with apache mod_dav_svn plugin, so the dev team can do any versioning process with usual port of httpd. it works quite smoothly, they did checkout/update/commit process from other network until they found the problem when access the server ssh-ly to perform some checkout process, they need to update some working copy on the server for sample development tags in httpd doc root, only root can checkout/update some working copy on the server, every user that already allowed by "AuthUserFile" config always got denied message to do that.

I thought the only possibly config that related for this is

 AuthUserFile /etc/svn-auth-conf
 AuthzSVNAccessFile /etc/svn-acl-conf

i'd tried several times to change the config file related to that things, but no result..

share|improve this question

4 Answers 4

up vote 0 down vote accepted

If I understand the question correctly, you don't have any issues when performing svn via http://somehost/svn/repo/proj but when you attempt to use the locally installed svn client from the system, you are getting permission denied from any user other than root.

What are the permissions of the files that you are trying to commit/update/checkout? are they owned by a functional user account that the user doesn't have permissions to?

Try to perform checkout/update/commits from /tmp to see if its a file permissions problem.

share|improve this answer
    
yes this is just permission problem, i'd follow your answer to analayze permision problem with doing some svn client action in /tmp i change the group owner of myhtdoc, then create one user (say it a manager) with the same group of htdoc. thanks @netlinxman –  Andri Jun 3 '09 at 3:20

Have you checked the filesystem permissions on the subversion store?

share|improve this answer
    
yes, its own by apache, the apahce run as apache user and webapp group.. the dir of repository was owned by apache:webapp, and all the dev team users set as webapp group. –  Andri May 31 '09 at 12:29
    
And what do the Apache logs have to say about it? –  Xerxes May 31 '09 at 14:36

It seems like you have some users accessing the repository over http, and one user/working copy accessing the repository locally. What you probably want to do is switch the working copy on the server to use the http method and not the local method. You could spend a while fixing permissions, but you will have a lot less headaches if everybody accesses the repository the same way.

Something like:

svn switch --relocate file://path/to/repository http://127.0.0.1/path/to/repository /path/to/working/copy

Should do the trick, followed by an svn update to make sure everything works ok.

share|improve this answer

You should not allow access via "ssh" and http at the same time. Your users access the repository once with a user on the server, once with with rights of the httpd.

Set up https-support to enable encrypted access and deny ssh access.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.