Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working with local storage repositories on an installation of XenServer and I am trying to use the UUID to delete a SR made in error. When I look at the disks by-id here is the output:

[root@xenser111 lib]# ls -l /dev/disk/by-id

total 0
lrwxrwxrwx 1 root root  9 Jul 16 09:02 scsi-3600050e02e433200d7110000d6930000 -> ../../sda
lrwxrwxrwx 1 root root 10 Jul 16 09:02 scsi-3600050e02e433200d7110000d6930000-part1 -> ../../sda1
lrwxrwxrwx 1 root root 10 Jul 16 09:02 scsi-3600050e02e433200d7110000d6930000-part2 -> ../../sda2
lrwxrwxrwx 1 root root 10 Jul 16 09:02 scsi-3600050e02e433200d7110000d6930000-part3 -> ../../sda3
lrwxrwxrwx 1 root root  9 Jul 16 09:02 scsi-SATA_SAMSUNG_HD103SJS2AEJ1BZ502526 -> ../../sdc
lrwxrwxrwx 1 root root 10 Jul 19 04:15 scsi-SATA_SAMSUNG_HD103SJS2AEJ1BZ502526-part1 -> ../../sdc1
lrwxrwxrwx 1 root root  9 Jul 19 04:32 scsi-SATA_SAMSUNG_HD103SJS2AEJ1BZ502653 -> ../../sdb
lrwxrwxrwx 1 root root 10 Jul 19 04:32 scsi-SATA_SAMSUNG_HD103SJS2AEJ1BZ502653-part1 -> ../../sdb1

However, when I look at the disks by-uuid, it does not show /dev/sdb or /dev/sdc:

[root@xenser111 lib]# ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 Jul 16 09:02 b1341321-038d-43e6-a194-0c3598f47152 -> ../../sda1

Why is this happening? Do I have to enact some command to populate the by-uuid directory? And how else can I find the UUID? (I have also used blkid to no use).

If it is relevant, /sda is a RAID 0.

share|improve this question
add comment

1 Answer

Are there file systems created on those partitions on sdc & sdb? Disks don't have UUID values, file systems do.

For example:

root@marvin:~# blkid /dev/sda
root@marvin:~# blkid /dev/sda1
/dev/sda1: UUID="8eb16c98-cf75-429b-af08-db29f5d5335b" TYPE="ext4" 

Swap can also have a UUID:

root@marvin:~# blkid /dev/sda5
/dev/sda5: UUID="a1a91f5f-6d6a-4cf7-a133-afaafeb2eb1e" TYPE="swap" 
root@marvin:~# 

Have you created valid File Systems on those partitions?

share|improve this answer
    
They are valid file systems but maybe I should try deleting and re-creating the partitions. –  bsigrist Jul 23 '10 at 0:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.