Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having an issue running xcopy as part of a startup script.

The server operating system is Windows 2008 R2 and the client operating system is Windows XP SP3.

File server hostname: filesrv1

DNS Alias (CNAME): filesrv

The command being executed through startup script is:

xcopy /s/e/c/i/h/y "\\filesrv\lab$\JH117\documents and settings\default user" "c:\documents and settings\default user"

If I change the server's name to filesrv1 then it works ok however not when using filesrv. Once booted up and logged on I can map it and read/write/execute files using both names.

I made registry and serviceprincipal names changes as described in the following article but still having issues. Any ideas?

http://support.microsoft.com/kb/281308

share|improve this question
    
is a computer startup script or user? –  tony roth Jul 20 '10 at 5:09
    
computer startup script. –  another_netadmin Jul 20 '10 at 13:48
add comment

2 Answers

I added an entry for OptionalNames as well as DisableStrictNameChecking in the registry and that appears to have resolved my issue.

share|improve this answer
add comment

Could it be a permissions issue? Unless you're allowing anonymous connections, you may have to allow the client machine account ($) permissions to read that directory from the file server.

share|improve this answer
    
No anonymous connections are allowed however Domain Computers are which is what allowed me to get this working when using the server's hostname. I don't see how it would be permissions if I can connect fine from the same workstation when specifying the hostname in the script. I am still not having luck with connecting using the CNAME. –  another_netadmin Jul 19 '10 at 22:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.