Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed the sql server 2008 enterprise version that i got from mcts 433 prep kit. after installing i tried to attach the adventureworks mdf file and got the error below

"the server principal "mythinkpad\vivek" is not able to access the database "model" under the current security context..."

Pls help

share|improve this question
    
under what account is your sql server service running? Also, try installing the latest service pack. –  SoftwareGeek Jul 20 '10 at 1:11
    
it's running under local system account and my os is windows 7. lemme try installing the service pack.. –  Vivek Jul 20 '10 at 1:21
    
Did you add your windows login to the server admins group in SQL server? –  Jim B Jul 20 '10 at 1:40
    
can you pls tell me how to do this? –  Vivek Jul 20 '10 at 1:52
1  
If you don't have permission to attach the database, and you don't have permission to give yourself the permissions, then you will need to speak to someone who does have permission to assign permissions to give you said permission. –  Mark Henderson Jul 20 '10 at 3:07

2 Answers 2

When you installed the SQL Server Instance did you make yourself an admin?

If not, did you install the SQL Server in mixed mode or Windows only auth mode?

If you installed in mixed mode login with the sa account with the password that you set during install. Then you can change the permissions.

If you installed in Windows only mode, and didn't make yourself an admin within the database instance then you'll need to uninstall and reinstall SQL Server making yourself an admin during install.

share|improve this answer

Try running SQL Server Management Studio with the "run as administrator" option of disable UAC on your OS. Did you make sure and add MYTHINKPAD\VIVEK to the sysadmin group during the SQL 2008 installation options?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.