Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For reference, this is Apache 2.2.15 on Fedora 13.

When I try to start httpd as a service like this, it fails:

# sudo service httpd start
Starting httpd:                                            [FAILED]

Nothing in the /etc/httpd/logs/error_log file.

I tried running it interactively in debug mode like this:

# sudo httpd -e DEBUG

And it runs just fine...

Any idea what could cause it to fail when being run as a service? Thanks.

share|improve this question
Did you search in other logs (syslog, messages, etc)? – lg. Jul 20 '10 at 7:55
Nothing in /var/log/messages... :( – Bob Somers Jul 20 '10 at 8:15
up vote 0 down vote accepted

Problem solved. It was SELinux. Sometimes that blasted thing causes more trouble than it's worth.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.