Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While trying to install rmagick and failing, I thought I would uninstall libfreetype6 and then reinstall it. When I entered sudo apt-get remove libfreetype6

It asked that the following packages will be removed, the list was long and included nearly everything from gnome to java to firefox to chrome and all. the link of output which is badly formatted is here:

I pressed y for yes, and it uninstalled everything. I shutdown the pc and when i opened it again, there was only command line interface, no desktop! I need to repair it. How can i repair my ubuntu 8.04 install? i dont want to lose any data so i dont want to reinstall ubuntu 8 from cd. Please help!

share|improve this question
People are going to be wary of offering you answers as long as you have a low accept rate. That's because this community thrives on having good answers to good questions. If someone has given you a good answer in the past, but you did not mark it as such, the community is weakened. Now, if you truly did not get good answers to your previous questions, then edit your previous questions and say that you're still looking for a satisfactory answer. – Bart De Vos Nov 22 '11 at 13:36

If you still have a working net connection you can try to reinstall the desktop meta package:

sudo apt-get install ubuntu-desktop

That should pull in necessary dependencies.

If you don't have net connection, the easiest is to plug in a wire, activate the adapter:

ifconfig eth0 up # (or eth1 - depends on which is your wired network adapter)

and acquire an IP address via dhcp:

dhclient eth0

Edit: Of course; I would recommend to mount an USB disk and backup your data before doing anything else.

share|improve this answer
I tried both sudo apt-get install ubuntu-desktop and sudo apt-get install --reinstall ubuntu-desktop, but they fail with messages like: E: broken dependencies, and the output log has stuff like: x depends on y but y will not be installed.. so this does not work for me – umar Jul 20 '10 at 8:39
Do you have a network connection; what does: $ ping give you? – gauteh Jul 21 '10 at 10:33
up vote 0 down vote accepted
sudo apt-get install ubuntu-desktop

eventually worked. when i ran it, it gave me output like:

x depends on y but y cannot be installed.

I continually tried to install y, it would give me a similar error, and again from the ouput I would determine another y, and try to install it. in 3 or 4 attempts like that, i installed some missing libraries, and then i was able to install ubuntu-desktop.

My desktop interface is now back, but it is not completely set up as many applications are crashing still. I am now using another OS (ubuntu 10) so haven't bothered fixing this completely.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.