Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a user who has found an interesting misbehavior on our file-serving cluster. He was able to create a directory on his home directory using WinXP and not have it be visible by a Win7 machine. This goes both ways, he was able to create one with Win7 that XP can't see.

WinXP: Directory from XP

Win7: Directory from Win7

The server is Server 2008 SP2 in a Failover Cluster. The server only sees the 'testing-7' directory in Explorer and command-line. I checked our backup software, which uses shadow-copy, and it only sees the 'testing-7' directory as well. However, 'Previous Versions' on an XP station happily shows previous versions of the 'testing-xp' directory that are quite visible and obviously usable.

I ran chkdsk against the volume in the off chance that there was some corruption lurking, but it didn't find anything.

Additionally, he was able to create a file called "Arrow.docx" in the same directory on both computers. In this document he saved different data. After rebooting everything, the win-7 machine saw the arrow.docx file with the win-7 data in it, and the WinXP machine saw the arrow.docx file with the WinXP data in it.

The machines used were fairly standard images in our Computer Labs (being in the middle of the XP to Win7 transition, we have both flavors at the moment). I can see all of the files he created on my own stations and they behave exactly like he said.

I've been able to replicate the problem, but it seems to only affect the one volume that we recently migrated to a new storage array. The migration method was pretty simple:

  1. Create the new LUN, format it, give it a drive letter, and add it to the target resource.
  2. Use robocopy to mirror the data to the new LUN
  3. Use it again to capture the changed data
  4. In Failover Manager I performed some 3-card-monty to get the drive-letters swapped
  5. I ran a powershell script I wrote to copy the directory-quota data

That all seemed to work. But now this has come up. Something has gone deeply weird here, and I'm looking for suggestions.

Edit RE: Offline files
Changing the offline files to disabled on my station causes everything to show up normally (where in this case normal is "as Win7 sees the world"), with the formerly XP-only files just gone. However, on another admins station, he still can't make the Win7 files appear. This is closer! But it does raise the question of lost-data.

share|improve this question
    
Are Offline Files enabled on either computer? Sounds like one (probably XP) is showing the offline version. –  Chris S Jul 20 '10 at 18:00
    
They're enabled on the cluster because of something completely different. And on the client because I suspect it defaults that way. Changing that does affect the presentation of this! –  sysadmin1138 Jul 20 '10 at 18:13
add comment

1 Answer

up vote 0 down vote accepted

The problem turned out to be a quirk in how Failover Clusters handle the listed migration procedure. SMB2-based clients got served from the new LUN, where SMB-based clients got served from the old LUN. Why this was the case, I do not know. I called Microsoft on it in the end, but they were unable to reproduce it.

In the end, the work-around was to either:

  • Delete and recreate the Shared Folder config in the failover cluster
  • Stop and start the File Server resource in the failover cluster

It's an unusual enough concatenation of events that it falls into the 'quirk' category rather than 'bug'. But hey, I ran into it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.