Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Powerconnect 6248 connected to a 2848 and I am trying to get VLANS working on the 2848.

VLANS work and receive DHCP addresses, traffic routes correctly and DNS works on the 6248.

The DHCP, DNS server is connected to port 1 on the 6248.

When I create a Trunk port on Port 3 of the 6248, allow all VLANS through it, create a trunk on port 1 of the 2848 on VLAN10 and try plugging devices into it, they cannot see any other devices connected to the L3 switch.

Both switches are running the latest firmware and the L3 on its own works as expected.

I cannot get any sort of trunking working to the L2 switch, tried with normal and crossover cables.

Here is the config of the 6248 L3.

The 2848 L2 switch has a blank canvas with VLAN 10 created on ports 1,2,3,4 with port 1 setup as the trunk port.

Any ideas pleeease? Anyone? This is driving me crazy.


L3 config.

!Current Configuration:
!System Description "Powerconnect 6248, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20,30
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3

exit
stack
member 1 2
exit
ip address 192.168.0.1 255.255.255.0
ip domain-name domain
ip name-server 192.168.1.10
ip routing
interface vlan 10
routing
ip address 192.168.1.1 255.255.255.0
exit
interface vlan 20
routing
ip address 192.168.20.1 255.255.255.0
ip helper-address 192.168.1.10
exit
interface vlan 30
routing
ip address 192.168.30.1 255.255.255.0
ip helper-address 192.168.1.10
exit
username "administrator" password 5f4dcc3b5aa765d61d8327deb882cf99 level 15 encrypted
dhcp l2relay
dhcp l2relay vlan 10-90
!
interface ethernet 1/g1
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10,20,30
exit
!
interface ethernet 1/g2
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g3
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 1/g4
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g5
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g6
switchport mode general
switchport general pvid 20
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g7
switchport mode general
switchport general pvid 20
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g8
switchport mode general
switchport general pvid 20
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g9
switchport mode general
switchport general pvid 30
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 30
exit
!
interface ethernet 1/g10
switchport mode general
switchport general pvid 30
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 30
exit

Have posted this up on the Dell Forums and have been getting some response.

Hope this is help to someone else as well.

Dell Forum Post

share|improve this question
    
You might want to strengthen your administrator 'password' :) –  Bryan Dec 12 '12 at 21:52

2 Answers 2

up vote 2 down vote accepted

The issue was this was found to be that by default Spanning-tree was enabled on the 2848 Layer2.

If I plugged another branded switch into the Layer 3 6248 and then the other switch into the 2848 it would work.

Going from the Dell to Dell would not work at all. Turning off STP on the 2848 solved this issue.

I have also found that using "spanning-tree portfast" in my config , on the 6248 ports in general mode is the way to go when getting a DHCP address, this shortens the time taken to get the address considerably while keeping things working.

share|improve this answer

Change your priority on the PC2800 from default 32768 to something else or update the firmware on the switch that addresses this issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.