Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I messed up my SSRS2008 Express' configuration I'm afraid.

I tried to enable anonymous access, using different methods I found on the net, so users would be able to just open the (non-IE) browser with their reports.

Now, I neither can deploy (a box wanting credentials pops up, which does not even accept the domain admin account, that has the dbo role assigned) nor access the report servers web frontend through IE

I tried maybe hundreds of combinations of service account, authentication methods but the ERROR in the Log File stays the same:

library!ReportServer_0-1!d74!07/16/2010-16:11:35:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ServerConfigurationErrorException: Konfigurationsfehler beim Berichtsserver. , Could not load Authentication extension;
Info: Microsoft.ReportingServices.Diagnostics.Utilities.ServerConfigurationErrorException: Konfigurationsfehler beim Berichtsserver. 

(which extension does ist mean???)

in the web.config my authentication is set to:

  <authentication mode="Windows" />
  <identity impersonate="false"/>

in rsreportserver.config the URLS and the authentication is like

<URLReservations>
    <Application>
        <Name>ReportServerWebService</Name>
        <VirtualDirectory>ReportServer</VirtualDirectory>
        <URLs>
            <URL>
                <UrlString>http://+:80</UrlString>
                <AccountSid>S-1-5-20</AccountSid>
                <AccountName>NT Authority\NetworkService</AccountName>
            </URL>
        </URLs>
    </Application>
    <Application>
        <Name>ReportManager</Name>
        <VirtualDirectory>ReportsManager</VirtualDirectory>
        <URLs>
            <URL>
                <UrlString>http://+:80</UrlString>
                <AccountSid>S-1-5-20</AccountSid>
                <AccountName>NT Authority\NetworkService</AccountName>
            </URL>
        </URLs>
    </Application>
</URLReservations>
<Authentication>
    <AuthenticationTypes>
        <RSWindowsNegotiate/>
        <RSWindowsBasic>
            <LogonMethod>2</LogonMethod>
        </RSWindowsBasic>
    </AuthenticationTypes>
    <EnableAuthPersistence>true</EnableAuthPersistence>
</Authentication>

and the target server URL of my reports project is set to

http://grip-dbsrv/ReportServer

(like the according virtual directory in the rsreportserver.config)

I'll gladly post anything else you need, just tell.

Any help is greatly appreciated!

*This is a crosspost from SQLServerCentral.com

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Ok, people. I've got it working again.

Here's what I have done:

  1. Rename all the *.config files in the Reporting Services directory to *.config.bak (so the installer thinks there are not present)
  2. Run the Repair option of the installer
  3. Configure the whole Reporting Service from scratch
  4. Delete all encrypted content (via RS Configuration Managers Encryption Key options) to avoid the rsReportServerNotActivated (due to no catalog access) error
  5. Re-Publish all the Reports
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.