Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a site where we have trouble on our production server, but not on my dev machine with request beeing aborted (hence, zero response).

It fails after exactly 1:19 minutes each time, and the request on my dev machine takes approx 1:44.

The content length is about 650K so that shouldn't be a problem.

The production enviroment is windows 2008 with IIS7 the dev enviroment is windows 7 with IIS 7.5

The have identical web.config but the machine config differs slightly (although they should be standard from install)

What could be causing this?

When looking in the access-log, the row says 0 byte in response byt win32-code 995 which should be 0 this is the last columns from the access-row:

sc-status sc-substatus sc-win32-status sc-bytes time-taken
200       0            995             0        76933

995 seems to be related to "thread aborted" or something, hence I'm kind of confident that it's IIS that aborts the request. the w3wp.exe process seems to run for some time even after the request stopped, so I don't think the web application even notices until it's time to write to the output stream.

EDIT: Have tried now with different connections and it seems like my firewall drops the connection because of no data (prematurely). Hence the 995 code.

share|improve this question

2 Answers 2

Try checking the "executionTimeout" setting in ASP.NET. The default for that seems to be 110 seconds which is similar to what you're reporting:

http://msdn.microsoft.com/en-us/library/e1f13641(v=vs.100).aspx

This could be present any of these configs:

  • Machine.config
  • Root-level Web.config
  • Application-level Web.config
  • Virtual or physical directory–level Web.config

Hope this helps.

share|improve this answer

I have the same issue, in my case the Network Adapter is the cause of the sc-win32-status 995. What did you change in the Firewall to prevent this? In device manager => network adapter => properties => advanced you can set several network related settings

share|improve this answer
    
Our firewall had a ALG for HTTP configured, which would cut the connection after 120 seconds if no data would flow through it. I just disabled it for the IP in question. –  jishi Dec 5 '12 at 10:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.