Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.


After that I tried to mount the folder via its full name (/var/...), but the console is saying: mount: can't find /var/xxxxxxxxx/xxxxx/xxx/ in /etc/fstab or /etc/mtab

Thanks for your help,
Nicolas.

EDIT: to complete my issue, I can actually see the unmounted folder, but I can't upload via FTP anyfile in it, although creating files via the console (touch test) does work.

share|improve this question
    
Can you please be more specific? How exactly have you tried to remount your folder? –  MariusPontmercy Jul 22 '10 at 12:28
    
Also maybe let us know what OS you're using, might just help... –  Chopper3 Jul 22 '10 at 12:29
    
Linux? Solaris? BSD? Which version? OK its not vfstab so its not Solaris... –  kmarsh Jul 22 '10 at 12:29
    
Chances are the mount point of the folder you want is a parent of the folder, and not the folder itself, and/or you need to specify the partition being mounted. –  kmarsh Jul 22 '10 at 12:31
    
Hi, the OS is a debian. I can't see how more specific I could as it is exactly everything that has happened. Cheers. –  Nicolas Jul 22 '10 at 12:35
show 2 more comments

2 Answers

up vote 0 down vote accepted

Cross-Platform Compatible Method:
If it's one of the normal mount points, just reboot and it'll fix itself.

Most *nix OSes:
Run mount -a and it will automount all the default mount points.

If it's not a default mount point (in fstab or mtab):
You'll have to manually mount it again; you must have manually mounted it once, so just do the same thing again.

share|improve this answer
    
Hi, I tried the mount -a, but the problem is still there. Actually to be more precise, I can see and go into the directory, but there's nothing in it even if I move some files to (using an FTP protocol). Cheers. –  Nicolas Jul 22 '10 at 12:39
    
Mount takes two arguments normally, a block device argument and mounts it to a folder argument. For example mount /dev/da0s1a /mnt works for me (your block device would be different). If the folder is listed in fstab then you can cheat and only give mount the folder argument; it will look up the device in the fstab file. –  Chris S Jul 22 '10 at 12:52
    
Yes, I know I have to specify and I tried without a second argment, but as it is a folder within sda1, what shoulb it be then? Is there any way to know "where" it has been unmounted? –  Nicolas Jul 22 '10 at 13:09
    
Alright, so actually, the mount-a seemed to has solved my problem, thanks! –  Nicolas Jul 22 '10 at 13:20
add comment

What is the exact syntax of the mount command you used to attempt a remount? IIRC, your partition to directory mapping varies from distro to distro in Unix environments, meaning /var/ can be on a separate partition or just under / with other directories on the same partition. Your setup may vary, but I have not seen a popularish distro where the a sub-directoyr of /var/ is mounted separate, but that does not mean much. What are other things are in your fstab config?

share|improve this answer
    
Hi, I did a : mount /var/www/folder/subfoler which lead to this result. Cheers. –  Nicolas Jul 22 '10 at 12:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.