Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm kinda desperate here

I have a Windows 2003 Server and when I try to call http://localhost I get a 404 error

I have localhost configured to c:\inetpub\wwwroot\ and whatever file I create there it always shows a 404

This is what I see on the log file

2010-07-22 14:54:06 W3SVC1 127.0.0.1 GET / - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 404 0 3

I tried restarting IIS with no luck, the eventvwr shows no error whatsoever.

Please any light will be appeciated

share|improve this question

2 Answers 2

Confirm that the binding for 127.0.0.1:80 is configured properly in the web site properties. You need to tell IIS to respond to requests to 127.0.0.1 (localhost's IP address).

Use the values 127.0.0.1 and localhost, respectively.

share|improve this answer

Are you saying that any URL, even to a specific file like http://localhost/myfile.htm, gives a 404, or just the default URL that you give in the question?

The first thing I would check, assuming you're just talking about the http://localhost URL, is the Default Document option on the web site (right-click, properties, Documents tab). 1) is Enable Default Document checked? and 2) do you have a file in your document root named the same as one of the file names in the list?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.