Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is the exact error I'm getting when I try to launch my default.aspx file from the published folder. Can anybody point me in the right direction?

The XML page cannot be displayed 
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later. 


--------------------------------------------------------------------------------

A name was started with an invalid character. Error processing resource 'file:///C:/inetpub/wwwroot/MHNProServices/Default....

<%@ Page Title="" Language="C#" MasterPageFile="~/ProServices.Master" AutoEventWireup="true" CodeBehind="Default.aspx.cs"...

Here are the contents of default.aspx

<%@ Page Title="" Language="C#" MasterPageFile="~/ProServices.Master" AutoEventWireup="False" CodeBehind="Default.aspx.cs" Inherits="MHNProServices.Default" %>
<asp:Content ID="Content1" ContentPlaceHolderID="head" runat="server">
    <link type="text/css" href="css/Default.css" rel="Stylesheet" />
</asp:Content>
<asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder1" runat="server">

    <div id="contentHead">
           <img src="css/img/heading_landing.jpg" />
    </div>
    <div id="contentTop"></div>
    <div id="content">
        <div id="contentLeft">
            <asp:Image ID="displayPicture" runat="server" />
            <img id="displayOverlay"src="css/img/profilepicture_overlay.gif" />

            <a id="contentButton_makeAppointment" href="Appointments.aspx?step=start"></a>
            <a id="contentButton_cancelAppointment" href="Appointments.aspx?step=cancel"></a>
        </div>
        <div id="contentRight">
                <h3><asp:Label ID="lbl_homepageHeader" runat="server" Text=""></asp:Label></h3>
                <hr />
                <asp:Label ID="lbl_homepageContent" runat="server" Text=""></asp:Label>
        </div>
    </div>
    <div id="contentBottom"></div>
</asp:Content>
share|improve this question

2 Answers 2

Without seeing the contents of the file (C:/inetpub/wwwroot/MHNProServices/Default....) or the code that references this is necessarily just a guess.

Either there is an invalid character in the file, or the ' at the beginning of the file name means the reference to the file is incorrect.

share|improve this answer
    
I updated my post with the contents. The website works fine when it is run from visual studio 2008. –  Gallen Jul 22 '10 at 22:15

This was because I was launching the .aspx file directly from the folder I published it to - I needed to have it up on an IIS server. D'OH!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.