Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to remote access an IIS7 machine, in our LAN. When i start IIS Manager, I do not have the Connect to a Server option .. as shown in the diagram, below.

Anyone know how I can get this to show? What setting do I need to install? Powershell script, anyone?

Cheers :)

alt text

share|improve this question
    
what are you running as a client? do you have RSAT installed? –  Nick Kavadias Jul 23 '10 at 5:42
    
@Nick Kavadias : RSAT ??? (maybe that answers my question ... ??) Client i'm using? same as the image above -> IIS Manager (as stated in the OP). –  Pure.Krome Jul 23 '10 at 6:09
    
RSAT: microsoft.com/downloads/… client as in client OS –  Nick Kavadias Jul 23 '10 at 7:26
    
RSAT has all the remote tools except remote IIS management. SeeCarlosAG's answer below. –  Chris S Jul 23 '10 at 14:34
    
@Nick Kavadias -- Ahh! gotcha. Win7 Enterprise x64. But yeah, CarloseAG's answer is the magic winning ticket. Cheers everyone for your help :) –  Pure.Krome Jul 25 '10 at 10:14

1 Answer 1

up vote 6 down vote accepted

If you are running in a client SKU (Windows Vista or Windows 7) you need to install support for Remote Management: x86: http://go.microsoft.com/?linkid=9655671 x64: http://go.microsoft.com/?linkid=9655672

Also make sure the server enables Remote Administration (WMSVC) by: Inetmgr.exe -> Server -> Management Service... enable remote connections and start the service. also make sure to make it auto-start inside the Services snap-in so that if you reboot the service, WMSVC comes back.

More info: http://learn.iis.net/page.aspx/158/remote-administration-for-iis-manager/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.