Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have tried several times running ESXi 4.1 inside vmware server 2.0 installed on Win7-64 bit. The problem is that the installation is stuck on welcome screen asking to press enter to continue (or Esc or R to repair). Nothing seems to let it proceed. I have followed all the suggestion illustrated. Any other idea? Thanks a lot.

share|improve this question
    
What's the processor, have you got the VX bit enabled? –  Chopper3 Jul 23 '10 at 13:07
    
Yes, VT is enabled and the vmx config file has been modified as stated here (serverfault.com/questions/28399/…) Processor il Core 2 duo P8700. Thanks –  Dadone Jul 23 '10 at 13:19
    
Thanks MisterJaytee. Worked, at least in so much as resolving the keyboard issue - then came "F11" time - simply received (in summary format): "vmware esxi 4.1 installation: Installation operation failed! The installation operation has encountered a fatal error: Unable to find system image to install. This is due to the image not being mounted correctly or the CD-ROM not being supported operation .... record info ... before rebooting ... supermicro, x7dcl, 0123456789, phoenix technologies ltd... reboot". Found sites that talked a lot about corrupt ESXi4.1 installer downloads - n –  user55444 Jan 30 '11 at 18:45
    
Thanks my VMware ESXi 4.1.0 installation works. I'm using VMware Workstation 6.5.4 on Windows 7 Pro x64 host. –  user61484 Jan 30 '11 at 18:46
add comment

1 Answer

up vote 2 down vote accepted

I know it's a long time since you posted this issue, but I had the same issue myself.

It seems that a lot of people are having keyboard problems with ESXi 4.1, but the main resolution has been to plug in a different kind of keyboard - not very useful if you're trying to install ESXi on top of VMWare Server.

Anyway, taking a slightly different approach, I experimented with the kernel boot parameters and I found that adding acpi=off to the command line allowed the installation to continue.

So to do this, at the VMVisor (ESXi) boot menu, press Tab. Change the command line to read:

mboot.c32 vmkboot.gz acpi=off --- vmkernel.gz --- sys.vgz --- cim.vgz --- ienviron.vgz --- install.vgz

You should now be able to press Enter at the appropriate point and continue your installation.

After installation, you'll find the keyboard doesn't work again. This is okay as you can do everything from the VSphere Client anyway. But if you want the keyboard to work at the console, then first install the VSphere client.

Then connect to your ESXi machine and click the Configuration tab. Under Software you should find an Advanced Settings option (scroll down if you can't see it). Select this option then click VMkernel. Now uncheck the box that says VMkernel.Boot.ACPI. And click OK.

When you Reboot your ESXi machine (you can do this from the VSphere Client), you should now be able to use the keyboard at the console.

share|improve this answer
    
Thanks a lot, it worked! –  Dadone Sep 16 '10 at 14:28
    
I'm glad someone else benefited from my hard work! If that's worked, could you tick the answer. Thanks. –  misterjaytee Sep 16 '10 at 17:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.