Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working on a network with ~10 kubuntu desktops (and numerous servers and IP phones) and am trying to get dnsmasq to specify another dns server as a failover. I tried using

server=192.168.0.90

but that just added the single dhcp/dns server to /etc/resolv.conf on my test machine (dynamic IP and freshly rebooted with no lease).

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Answered my own question, thanks to rfc2132

dhcp-option=6,192.168.0.90,192.168.0.98

However, RFC2132 specifies option 5 as a list of name servers and option 6 as a list of domain name servers, and I'm not sure what the difference is. Either way, option 6 put them correctly as

nameserver 192.168.0.90
nameserver 192.168.0.98

in /etc/resolv.conf

share|improve this answer

Posting as a separate answer rather than a comment on yours because that way I can use links.

Option 5 is for IEN 116 nameservers — a ridiculously obsolete protocol that Jon Postel wanted dead over twenty years ago. Solaris still supports it, but won't in the next version.

share|improve this answer
    
Good to know, thanks. –  pfyon Aug 6 '10 at 15:37

Another way is to set your dnsmasq server to be the DNS server for DHCP, and use /etc/resolv.conf on the dnsmasq server to specify your list of DNS servers. That way you can easily change DNS (and set aliases) without having to wait for DHCP renewal - just either restart or kill -HUP dnsmasq to reload the config.

share|improve this answer
    
Andrew, 'kill' command expects process identifier not process name. You should use either kill -HUP pidof dnsmasq or killall -HUP dnsmasq . –  Arruor Mar 23 at 7:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.