Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

when i am installing any module or component in my joomla1.5 i am getting the following problem, here i am showing an example, i am in big trouble please save me...

JFTP::mkdir: Bad response JFTP::chmod: Bad response Component Install: Failed to create directory.: "/home/butterfl/public_html/components/com_ckforms"

share|improve this question
Does the user running Joomla have sufficient file system permissions to create a directory at that location? –  andol Jul 24 '10 at 7:06

2 Answers 2

Short awenser: chmod 777 /home/butterfl/public_html/components

Long awenser: Joomla run as your web server(i will assume apache from now on) uid. You need to give it write access to most of your Joomla files and directory if you want to use the package installation feature from your Joomla admin. To do so, best would be to chmod 775 the dir, chmod 664 the files and chgrp www-data (assuming you use a debian base system) all the Joomla installation.

Alternative awenser: See "ckforms" documentation about manual installation.

Yet a other awenser: If you setup a FTP server (could be bind only to and enable FTP in Joomla, maybe it make it work. See the Joomla documentation about enabling FTP and security issues.

share|improve this answer

As John said, it's the matter of chmod.

You can see your folder access status in your Joomla installation in Help menu > System Info > Directory Permissions. In this page Joomla shows you the directories that it cannot write anything inside them.

Do not make your components folder access to 777, instead sue a safer access level like 755 or even 644 so you can be sure that no one else can access your files. But be sure that your tmp and cache folder are 777 to prevent later problems. There are similar folders in administrator directory too which may need to change their permissions.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.