Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Opensuse 11.1 virtual server with plesk configuration software. I want to set up vpn on the server, so that i can connect to it from my iPhone (running iOS 4, no jailbreak). I want to secure both WLAN hotspot, and Edge/3G provider traffic.

Plesk offers a VPN module, but it seems to be openvpn (thus openssl with tun/tap) that does not seem to be supported by iphone os.

The iPhone offers three vpn configurations: L2TP, PPTP, IPSec. So, setting-up any of those on the server would be ok.

How to set-up my server for this?

Many thanks for your suggestions and comments.

share|improve this question
add comment

1 Answer

I'm using PPTP with my iPhone with a pretty simple configuration, very close to the basic. Below you can find a sample of my configs (i'm running debian so paths can be different on opensuse):

/etc/pptpd.conf

ppp /usr/sbin/pppd
option  /etc/ppp/pptpd-options
localip 192.168.1.1
remoteip    192.168.1.201-254
listen  xxx.xxx.xxx.xxx

/etc/ppp/pptpd-options

name MyVPN
domain MyDomain
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
nodefaultroute
lock
nobsdcomp 

/etc/ppp/chap-secrets

"username"      MyVPN   password    "192.168.1.201"
share|improve this answer
    
Hello, Thank you for your reply! The pptp module was not installed, so I installed it using yast2. Then I got an error when doing "service pptpd start": "Starting MS VPN server pptpdFATAL: Could not load /lib/modules/2.6.18-028stab064.7/modules.dep: No such file or directory" Following a google result i created the folder "/lib/modules/2.6.18-028stab064.7/" which was not present, and ran "depmod -a". The error is now: "Starting MS VPN server pptpdFATAL: Module ppp_mppe not found." ... –  dfg3regsdgf3rgdfgadf Jul 25 '10 at 8:56
1  
"modprobe ppp-compress-18 && echo ok" results in: "FATAL: Module ppp_compress_18 not found." –  dfg3regsdgf3rgdfgadf Jul 25 '10 at 8:59
    
do you have the mppe module installed? here is a link that I found for suse from pptp website: pptpclient.sourceforge.net/howto-suse-100.phtml . it should work. as i told you, i have 0 experience with suse flavor. also, you can edit the config that i pasted in my primary comment and remove "require" lines and add "require-chap" instead of "refuse-chap", but like this you wot have encryption. cheers –  MihaiM Jul 25 '10 at 17:05
    
It does not seem to be installed. It might be a limitation of the virtual server. From your url website: "if your Linux kernel does not have the ppp_mppe module, rebuild it to add MPPE support, enabling the CONFIG_PPP_MPPE kernel build option," ... but i don't want to have to rebuild the kernel. Is there another solution? –  dfg3regsdgf3rgdfgadf Jul 25 '10 at 17:18
    
modprobe ppp_mppe FATAL: Module ppp_mppe not found. –  dfg3regsdgf3rgdfgadf Jul 25 '10 at 17:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.