Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It rebooted, then won't restart.

Forgive me if I'm short on details - still collecting them. It is an EBS image created from an AMI which was created from another EBS image.

The notes at end may provide some insight.

Is this recoverable? because it is an ebs instance, i can try to attach to it via another image, but I'd rather recover the running EBS.. and would like to understand what happened, is happening.

Any other suggestions very welcome.

Begin: Running /scripts/local-bottom ...
Done.
Done.
Begin: Running /scripts/init-bottom ...
Begin: Starting AppArmor profiles ...
chroot: cannot execute /etc/apparmor/initramfs: No such file or directory
Failure: AppArmor profiles failed to load
Done.
init: console-setup main process (2098) terminated with status 1


    %Ginit: plymouth main process (300) killed by SEGV signal

init: plymouth-splash main process (2387) terminated with status 2

cloud-init running: Sun, 25 Jul 2010 17:28:07 -0400. up 5.89 seconds
init: ureadahead-other main process (2449) terminated with status 4

swapon: /dev/sda3: swapon failed: Device or resource busy
mountall: swapon /dev/sda3 [2451] terminated with status 255
mountall: Problem activating swap: /dev/sda3
mountall: Disconnected from Plymouth
init: hwclock-save main process (2464) terminated with status 1
share|improve this question
    
current plan is to mount the ebs drive from a running instance and modify the /etc/fstab... .... –  Jonathan Hendler Jul 25 '10 at 21:52

1 Answer 1

up vote 2 down vote accepted

Looks like it was something wrong with /etc/fstab. Basically

  1. take a snapshot of broken ebs (as precaution)
  2. detatch broken ebs from /dev/sda1 on relevant machine
  3. created new ebs from snapshot
  4. attached from running server and
  5. edited /etc/fstab detached and
  6. reattached to original ebs instance at /dev/sda1 (aws gives error but it worked!)
share|improve this answer
    
further, AWS support provided this link osdir.com/ml/ec2ubuntu/2010-05/msg00092.html –  Jonathan Hendler Jul 26 '10 at 6:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.