Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i saw this in logins

computername/username

and i deleted it!

now can not log into sql srv mangmnt sttdio 2008

no the mixed mode is not enable, can not use the sa account its disabled default

please help what should i do to bring the user login back without login in

i dont want to re install every thing help!!!

share|improve this question

migrated from stackoverflow.com Jul 26 '10 at 5:37

This question came from our site for professional and enthusiast programmers.

1  
Actually it looks like this is a duplicate. –  Mark Hurd Jul 24 '10 at 14:12
    
pics are very bad and no proper description in the duplicate –  user48642 Jul 25 '10 at 13:52

3 Answers 3

Do you have a backup of master db?

If you have the sa password, you can change to mixed mode in this registry key:

If none of these, reinstall. And don't do it again ;-)

share|improve this answer
    
your link helped to find the answer. thanks –  user48642 Jul 25 '10 at 13:52
    
@user287745: please accept my answer then with the box tick to the left. Thank you. –  gbn Jul 25 '10 at 14:38
    
sorry cannot your link is not the answer, it provided a page where i had to search other links for the answer –  user48642 Jul 25 '10 at 16:21
    
Can yoг share with the answer (or results of your search)? –  Gennady Vanin Геннадий Ванин Aug 12 '10 at 12:54
up vote 3 down vote accepted

To regain the access lost by deleting the only user configured to login using windows authentication, when there are no other logins to use.

Do the following as described in the article on msdn

-login using single user mode.

-logout out

-change the settings back to multi user

-and login in using default account

IT WORKED!

i dont remember th link to the article so heres the copy paste i had.


How to: Configure Server Startup Options (SQL Server Configuration Manager) Use SQL Server Configuration Manager to configure startup options to be used each time the Database Engine starts. For a list of startup options, see Using the SQL Server Service Startup Options.

SQL Server Configuration Manager writes startup parameters to the registry. They take effect upon the next startup of the Database Engine.

Note

On a cluster, changes must be made on the active server while SQL Server is online, and will take effect when the Database Engine is restarted. The registry update of the startup options on the other node will occur upon the next failover. To configure startup options

  1. In SQL Server Configuration Manager, click SQL Server Services.

  2. In the right pane, right-click SQL Server (), and then clickProperties.

  3. On the Advanced tab, in the Startup Parameters box, type the parameters separated by semicolons (;).

For example, to start in single-user mode, insert -m; in front of the existing startup options, and then restart the database. (When you start SQL Server in single-user mode, first stop SQL Server Agent. Otherwise, SQL Server Agent might connect first and prevent you from connecting as a second user.)

Important

After you are finished using single-user mode, you must remove the -m; from theStartup Parameters box before you can restart the server instance in the normal multi-user mode.

  1. Click OK.

5. Restart the Database Engine.

after this i did

-logout out

-change the settings back to multi user

-and login in using default account

share|improve this answer

you could try rebuilding the master db: http://blogs.msdn.com/b/psssql/archive/2008/08/29/how-to-rebuild-system-databases-in-sql-server-2008.aspx

This will let you back in but you likely lose some configuration info. you databases should be fine

share|improve this answer
    
please go to contrl pnl to instl and cnfgre sytm compnts! –  user48642 Jul 25 '10 at 13:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.