Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

.NET on my web server is completely messed up. IIS would not start saying it could not load .net 2.0. I tried to repair .net 3.5 and it would error out. So I removed 3.5 and tried to reinstall it, again it errored out. I tried to repair 2.0 and got the same issues. Again then tried to uninstall 2.0 and the uninstall errored out. I used the .net clean up utility to remove everything .net. That completed successfully. now I am trying to install .net 2.0 service pack one and it too is erroring out saying

 Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft   
.NET Framework 2.0a. MSI returned error code 1603

We are completely dead. Please any help possible would be great

share|improve this question

migrated from stackoverflow.com Jul 26 '10 at 16:20

This question came from our site for professional and enthusiast programmers.

    
Anything in your event log? –  Chris Diver Jul 26 '10 at 16:13
1  
What windows version? Some versions are baked into the OS, and they need to be enabled/installed/updated through Windows Control Panels. –  Nate Jul 26 '10 at 16:18
    
The OS is server 2003 –  twal Jul 26 '10 at 16:21

1 Answer 1

Look to see if you have any dead / hung msiexec processes, maybe MSI has crapped out on you and not gone away.

Have a look at this blog post as well to help narrow down that could be causing the 1603 failure.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.