Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

While running perfmon on Windows 2008 server after creating a data collector set and attempting to start I receive the following error:

"The Data Collector Set or one of its dependencies is already in use."

I have two virtual machines configured the same. It runs fine on one server, but not the other.

Any thoughts?

share|improve this question

4 Answers 4

In typical, this issue involves "NT Kernel Logger", which is a kernel event provider. This provider can not be accessed at the same time by multiple consumers (e.g., multiple data collector sets). Resource monitor accesses this provider.

See whether your DCS is collecting kernel logger information. Stop the resource monitor before running your DCS. If running multiple DCSs that collect kernel logger info, run one DCS at a time.

share|improve this answer

I had the same problem while Sysinternals Process Explorer was running. Exiting Sysinternals Process Explorer fixed the problem.

share|improve this answer

I had the exact same problem. I found that in the Performance Monitor under Event Trace Sessions that the NT Kernel Logger was running. I stopped it and the DCS ran fine. What was weird is that on the other server that NT Kernel Logger was not there. That's why it ran with out a problem.

share|improve this answer

Open perfmon, go to the Reports folder. Expand User Defined, then your custom data collector set.

Delete the .blg files

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.