Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Application Server Windows Server 2003 SP2 with IIS 6.0

IIS has a "Default Web Site" (port 18000, ssl 443, ID=1) with a certificate created by me. I have an specific site called "scj.galaxy.Weekly" (port 80, ssl 443, ID=1272369728) that is working fine. I have an entry in windows/system32/drivers/etc/hosts that links galaxy.Weekly.scjdev.ds to the server ip in both my local machine and in the application Server.

These sites works:

http://scj.galaxy.weekly/test.html works

http://scj.galaxy.weekly/test.aspx works


https://scj.galaxy.weekly/test.html fails

Error message is:

The connection was reset The connection to the server was reset while the page was loading.

The certificate was working fine for months. It was created with something similar to this:

Selfssl /N:CN=*.scjdev.ds /V:3650 /S:1 /P:443

I have tried several options and none of them are working:

  • 1) Create a certificate only in "Default Web Site" and link it to SecureBindings with command prompt

cscript adsutil.vbs set /w3svc/1272369728/SecureBindings ":443:galaxy.Weekly.scjdev.ds"

  • 2) Create a certificate only in "Galaxy Site" and link it to SecureBindings

  • 3) Create a certificate in both and link them to secureBindings.

Probably I am missing an step or something, but I can't see it.

Here is the relevant config of Galaxy Site:

<IIsWebServer   Location ="/LM/W3SVC/1272369729"

<IIsWebVirtualDir   Location ="/LM/W3SVC/1272369729/root"
        AccessFlags="AccessRead | AccessScript"
        AppFriendlyName="Default Application"
        AuthFlags="AuthAnonymous | AuthNTLM"
        DirBrowseFlags="EnableDirBrowsing | DirBrowseShowDate | DirBrowseShowTime | DirBrowseShowSize | DirBrowseShowExtension | DirBrowseShowLongDate"
        ScriptMaps="some config... "
share|improve this question
up vote 1 down vote accepted

I fixed it finally removing ALL the certificates and stopping ALL the sites when creating the new one.

The key thing is stopping ALL the sites. If you fail to do so, an internal reference will kept hooked, everything will seem ok but will fail when trying to browse any page with https.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.