Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Greetings.

My setup is as follows: Microsoft Office SharePoint Server 2007 installed on Windows Server 2008 Enterprise Edition.

I am currently trying to migrate page data between servers on different domains.

I have been doing the following:

stsadm -o export -url http://mosswebserver/mysitecollection/wiki -filename c:\spbackups\mysitecollection\wiki\wiki_site.cmp -includeusersecurity -nofilecompression -versions 4

This works with no issues, usually. However, I am now at the point where I need to migrate Wiki pages over, and the location that I need to move my Wiki sites over to is a subsite underneath a Publishing portal site with workflows enabled.

When I go to Site Actions > Create Site, the only option available for creating the site is "Publishing Site with Workflow"...there is no "Blank Site", which is what I normally create when getting ready to import site data over using stsadm.

stsadm -o import -url http://mosswebserver/myNEWsitecollection/wiki  -filename c:\spbackups\mysitecollection\wiki\wiki_site.cmp -includeusersecurity -nofilecompression

Unfortunately, since it only allows me to create a site with the Publishing Site with Workflow, when I try to do an import I end up with the following error message:

Cannot import site. The exported site is based on the template WIKI#0 but the destination site is based on the template BLANKINTERNET#2. You can import sites only into sites that are based on same plate as the exported site.

Does anyone know how to create a blank site underneath a Publishing site collection? I'm unsure of how to do this with stsadm, and have only very limited coding experience for SharePoint (I can create a basic web part to display some text, and allow users to change the text and the color of the text...that's basically it, for now).

Cheers, any help would be appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

NOTICE: i DON'T HAVE ENOUGH REPUTATION, SO THE LINKS WITH "http" SHOULD BE REPLACED WITH "hxxp". THANKS!

Figured this one out, just forgot to post an answer since I don't receive email notifications from the 'Vault!

To create a new Wiki Site (Site Collection): stsadm -o createsite -url http://myServer/NewWikiSiteCollection -owneremail someone@here.com -ownername "John Doe" -ownerlogin DOM\john.doe -sitetemplate WIKI#0 -description "A new Wiki Site"

To create a new Wiki web (Subsite in Site Collection): stsadm -o createweb -url hxxp://myServer/publishingSiteCollection/newWikiSubSite -sitetemplate WIKI#0 - description "A new Wiki SubSite"

I wasn't able to create it in the GUI, since when creating a new subsite (web) from the Site Settings page wasn't an option (it didn't show that template). And I wasn't able to import correctly, so I used stsadm to create the web with a Wiki Template, and then imported the site successfully.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.