Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of our clients owns the domain some-domain.org.

This domain is not maintained by us, and I am wondering if I am overlooking something: our client has a forwarder setup for this domain (IE. info@some-domain.org forwards to client@someisp.com).

When I do an MX lookup on this domain I see the following:

;; QUESTION SECTION:
;some-domain.org.   IN      MX

;; ANSWER SECTION:
some-domain.org. 9264 IN    MX      50 mail.some-domain.org.

Which indicates there has been an MX-entry setup. However, this specific entry does not seem to resolve:

;; QUESTION SECTION:
;mail.some-domain.org. IN   A

;; AUTHORITY SECTION:
some-domain.org. 2359 IN    SOA     ns1.hans.hosteurope.de. hostmaster.some-domain.org. 2010062314 16384 2048 1048576 2560

But yet, the forwarder works.

Am I overlooking something? How can this forwarder work, even though this domain does not seem to have a valid MX entry?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

If MX records are not present the delivery falls back to the A record.

share|improve this answer
    
I never actually knew that. Thanks! –  Aron Rotteveel Jul 28 '10 at 9:35
    
Yep, check out the rfc for detailed info tools.ietf.org/html/rfc5321#section-5 –  topdog Jul 28 '10 at 11:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.