Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running Exchange Server 2003, I run an online backup every 2 nights using NTBackup, the job succeeds and I can verify by check db properties in systems manager & logs in D:\Exchsrvr\mdbdata.

I have a vm of that server with identical image but each time I attempt to restore using NTBackup it goes ok until I try to mount store, it fails every time with various issues.

During restore I select the *.bkf then Log Files, Mailbox Store & Public Folder Store. I then choose a temp location for log & patch files [D:\Temp\restore]. Last screen I click "Last Restore Set [Log file replay will start after this restore completes]" & "Mount Database after Restore".

I also make sure "allow this database to be overwritten" is checked in systems manager.

It seems I always have a dirty shutdown, can anyone tell me how to not have a dirty shutdown using an online backup?

Regards

Gary

share|improve this question
    
Can you please update your post with some of the error messages you are getting (from the Event Log) - that would be much more helpful, rather than us trying to guess what's going wrong. –  Ben Pilbrow Jul 28 '10 at 9:29
    
Yes no problem errors as follows: When I attempt to Mount store I get an error ID no: c1041724 which suggest I dont have enough space. I have 50GB so not true. I ran eseutil /cc [path to directory containing Restore.env] and it tells me -939523485 exisiting log file is not contigious. –  gary Jul 28 '10 at 9:56
add comment

2 Answers

up vote 0 down vote accepted

To ensure the database is not in a dirty shutdown state you will need to do an offline backup. THis means that during the backup process Exchange WILL be down. Please see the attached link which is handy for setting NTbackup with exchange: http://www.msexchange.org/tutorials/Exchange-2003-Backup-Restore-NTBACKUP.html

Should your backup be in dirty shutdown state and you need to recover, you would need to look at the eseutil tool to get your database back into action. This link explains more about the /R option: http://technet.microsoft.com/en-us/library/aa998075%28EXCHG.65%29.aspx

Let me know if you get stuck, and I will try to help you more.

share|improve this answer
add comment

thanks for your suggestions. I now have this operational, I basically moved all *.edb, *stm & log files to another directory leaving "D:\Exchsrvr\mdbdata" empty.

I ran the NTBackup restore again and both mail & public folder stores mounted 1st time! Not sure thats officially the correct way but it seemed to have worked for me this time.

Regards

share|improve this answer
    
glad i could help :) –  JamesK Jul 28 '10 at 14:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.