Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to follow the testing methodology described in the Terminal Server Capacity and Scaling document using the Terminal Services Scalability Planning Tools available with the Windows Server 2003 Resource Kit Tools

TBScript.exe is a script interpreter that can connect via RDP to a terminal server and execute scripts that emulate user interaction with the terminal server. The command line help for tbscript.exe suggests I should be able to provide the credentials used to connect to the terminal server.

Usage: (partial listing only):

tbscript.exe <script> [- options] 
-s:server - The default server to use. 
-u:username - The default username to use. 
-p:password - The default password to use.

I run the following command (from a Windows Server 2003 machine):

.\tbscript.exe .\test.vbs -s:myserver.com -u:user -p:password

When I execute the tbscript.exe program with the required scriptname, server ip and credentials, I see an RDP window connected to my server with the username field populated but not the password field. The login never completes automatically and no subsequent scripts are run.

Has anyone ever used tbscript to run tests against a Terminal Server? Any help would be appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted
+50

Is this computer on a domain? I haven't used tbscript, but sometimes I find when automating RDP logins, I have to do -u:domain\username in order to get it to work.

share|improve this answer
    
This is a standalone computer and I tried computername\username but no luck. Just for completeness, I also tried it against a computer in an AD with domain\username and unfortunately no luck again. –  Ameer Deen Aug 3 '10 at 13:37
    
I think I've got it. There are a bunch of smclient.ini.* files in the same directory as tbscript.exe. Make a copy of smclient.ini.OS-you're-testing as smclient.ini and try again. So if you're testing Windows Server 2003, copy smclient.ini.w2k3 as smclient.ini. –  Dave Aug 3 '10 at 17:23
    
Feel silly for missing that. That did the trick. Thanks! –  Ameer Deen Aug 4 '10 at 2:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.