Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm a web designer from Taiwan. I just bought a domain name here (alex-chen.net), and I also bought their web hosting services. They told me to wait 24 hours to have it available. Last night I uploaded my page (FTP) to the site and entered alex-chen.net and it worked. Then I tried www.alex-chen.net and it redirected me to another page. Few minutes later the opposite happened: It worked on www.alex-chen.net and alex-chen.net redirected me to the other page.

In my root folder I have a httpdocs and a httpsdocs. I uploaded the files to httpdocs only. I'm not sure if this may be causing the problem.

Is this a problem from the company who is providing me the web hosting and domain name or something that I did?

P S: Please tell me if my URL is redirecting you to the page mentioned above or to my web portfolio.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Both URL's go to your portfolio when I click the links. How long have the name servers been configured to point to your domain's hosting? If it has only been a few days or less, there is a good chance that some DNS servers simply have not been updated with the new DNS records for your domain.

The only difference between the 'httpdocs' and 'httpsdocs' folders is that you would use 'httpsdocs' if you get an SSL certificate for your domain.

share|improve this answer
    
They told me to wait 24~48 hours, 24 has passed and it worked few times with alex-chen.net but it redirected me to another page with the www. Now I tried again and both worked. The thing is changing each time. Is this a normal DNS cache issue? Do I have to wait a little bit more? –  janooChen Jul 29 '10 at 2:52
    
Yes, you will probably have to wait a bit longer. I would expect it to be resolved within 48 hours, though. You may find these sites useful as well: network-tools.com/… whois.domaintools.com/alex-chen.net dnsstuff.com/tools/tracert/… –  SturdyErde Jul 29 '10 at 3:00

I am getting your web portfolio on both www and without the www.

This is likely a DNS issue, it can take time for your ISP to fully update it's DNS cache. You can keep an eye on things here: http://www.intodns.com/alex-chen.net

share|improve this answer
    
Thanks! That website is very useful. Sorry but how can I make sure that the URL is redirecting me to my portfolio with the information provided in intodns.com? So this is probably a DNS cache issue? They told me to wait 24~48 hours, since it was working I thought it was ready (24 hours passed). –  janooChen Jul 29 '10 at 2:46
    
It's probably a time issue - some DNS servers have updated and some haven't. Your ISP probably has a round-robin system which switches to different servers based on load which would be why sometimes it works, and sometimes it doesn't. If it's still a problem for you in another 24 hours, post back here and we'll look again. You can also try using different DNS such as GoogleDNS or OpenDNS. Hope this helps! –  direct00 Jul 29 '10 at 5:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.