Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm getting this error in my log

warning: SASL authentication failure: no secret in database

because the client is trying to use MD5 authentication, and the server needs a database of md5 encrypted passwords. Clients that just use PLAIN authentication work fine. (it's only enabled over SSL, so I'm fine with this). How can I disable MD5 authentication?

share|improve this question

2 Answers 2

The correct way to do it is to use the configuration files.

if you are using Cyrus SASL then configure your smtpd.conf to use only the mechanisms you want.

mech_list: PLAIN LOGIN

If you are using dovecot you do that in your dovecot.conf file.

auth default {
       mechanisms = plain login
       ...
       ....
}
share|improve this answer
    
huh. I tried mech_list and it just seemed to ignore it. –  smoofra Jul 29 '10 at 14:37

This is a bit of a hack, but I figured out how to disable that crap. in /usr/lib/sasl2/ there's a bunch of library files related to different authentication mechanisms. They're called things like libdigestmd5.so. If you get rid of the files related to the mechanism you don't want (just put them in some other directory), postfix will not offer those mechanisms.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.