Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As an example, say my domain is example.com, that's an ASP.NET site on IIS 7.5. I'd like to get phpBB installed and available at example.com/forum.

If I set up phpBB as it's own application, outside of example.com, I can get it going just fine on the same IIS server as the ASP.NET app, but when I try to install it as an app inside the example.com site, or as a virtual directory inside example.com, the installer hangs when trying to connect to the MySQL database. I get an HTTP 500 error from IIS:

HTTP Error 500.0 - Internal Server Error
C:\php\php-cgi.exe - The FastCGI process exceeded configured request timeout

This error occurs with both of the PHP apps I'm trying to install. In both instances, it's when the app attempts to connect to the database.

I'm entirely unsure how to fix this, or even if it's fixable. Plain vanilla PHP pages work fine (eg. <? print phpinfo(); ?> does what it's supposed to). Suggestions?

share|improve this question
add comment

3 Answers

Have you looked at phpBB's documentation for running in a sub-directory? You may be required to make a change to a constant (usually in a config file) to reflect the webroot. This is the case for 90% of the open source LAMP apps I've setup before.

share|improve this answer
    
I don't believe that's the problem. I've edited the question above to say this, but it happens with another PHP app, at the same point in its install process: when trying to connect to the database. –  saturdayplace Jul 29 '10 at 20:17
    
What are you putting in for the MySQL "host" field? i.e. is the MySQL database on the same box? If so, you should be putting in localhost. –  gravyface Jul 29 '10 at 20:52
    
Yep, the DB is on the same box, and it's trying to connect to 'localhost'. –  saturdayplace Jul 29 '10 at 21:01
add comment

From your description of the problem, I'm assuming PHP is already installed and working on your server if running PHP scripts on another web site than example.com.

Ok, two questions here:

  • First of all, which version of IIS?
  • Second one: can you get a simple PHP page to run in your example.com website, or does this result in the same error, too?

Update:

This doesn't seem related to PHP at all, but specifically to PHPBB; I also suggest checking the documentation for running in virtual directories, and also trying to set it up in a VD of another web site, to completely rule out anything related to example.com.

share|improve this answer
    
+1 on testing out a simple php page like, <?php echo phpinfo(); ?>. It may be that phpBB requires you to specify the appropriate webroot somewhere in the configuration; this is common with alot of LAMP Web applications. –  gravyface Jul 29 '10 at 19:11
    
IIS 7.5. <?php echo phpinfo(); ?> works as expected. Updated the question to reflect these points. –  saturdayplace Jul 29 '10 at 19:50
    
I used phpBB as an example because it's what I assumed most people would be familiar with, but the same behavior occurs with another php app I'm trying to install. It both instances, the installer hangs when attempting to contact the MySQL database. –  saturdayplace Jul 29 '10 at 20:14
    
Could be an issue with application pools and their identities and/or settings. Are all of your web sites running in the same AP, or do they use different ones? –  Massimo Jul 29 '10 at 20:21
    
Checking... OK - I have two relevant application pools: the main ASP.NET app pool, and a pool for phpApp1. phpApp1 is running as a application under the main asp.net site, but it's using it's own application pool. phpApp2 is currently running as a virtual directory of the asp.net application. The problem occurs in both situations. –  saturdayplace Jul 29 '10 at 20:31
show 1 more comment

It may be that phpBB requires you to specify the appropriate webroot somewhere in the configuration; this is common with alot of LAMP Web applications.

share|improve this answer
    
Welcome to Server Fault! Thanks for your answer. Please note that the FAQ requests that you not use a signature. –  NathanG Jul 23 '12 at 19:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.