Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

since the configuration of apache 2 has been split into several files instead of http.conf, I can't get directory listing working. I already found such a question, but it didn't fit to my problem:

http://serverfault.com/questions/70455/why-is-apache-ignoring-the-options-indexes-directive

I'm using Ubuntu 10.04 with Apache/2.2.14 and I already looked for these possibilities:

  1. Apache can read its directory root
  2. no .htaccess in directory root
  3. The listing of other directories is working. Only the root directory can not be listed.
  4. There are no other directory settings which configure the same directory.
  5. There is no welcome.conf file

Here is my sites-enabled/000-default config file

    <VirtualHost *:80>
 ServerAdmin webmaster@localhost
 ServerName localhost
 DocumentRoot /home/http
 <Directory />
  Options FollowSymLinks
  AllowOverride None
 </Directory>
 <Directory /home/http/*>
  Options +Indexes +FollowSymLinks +MultiViews +ExecCGI +Includes
  AllowOverride None
  Order allow,deny
  allow from all
  AddType text/html .shtml
  AddHandler server-parsed .shtml
  AddOutputFilter INCLUDES .shtml
 </Directory>

 ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
 <Directory "/usr/lib/cgi-bin">
  AllowOverride None
  Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
  Order allow,deny
  Allow from all
 </Directory>

 ErrorLog /var/log/apache2/error.log

 # Possible values include: debug, info, notice, warn, error, crit,
 # alert, emerg.
 LogLevel warn

 CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

What else can I do?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Try changing <Directory /home/http/*> to <Directory /home/http>.

share|improve this answer
    
Thanks for your reply. It worked =) –  Bevor Jul 30 '10 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.