Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're using the default SMTP server for our websites to send mail with, but in the last day sending messages started getting this error:

Insufficient system storage. The server response was: 4.3.1 Out of memory

Further digging found this message in the System event log:

SMTP server cannot create a file in the queue directory C:\Inetpub\mailroot\Queue\

I've since given the Everyone account full control of the mailroot folder but it's still happening. There's enough space on the server and to the best of my knowledge nothing on the server has been changed

share|improve this question
    
How's the memory usage on the server look? –  mrdenny Jul 30 '10 at 1:09
    
And more specifically, where's the Pool Nonpaged Bytes memory at? How much memory is in the server? What edition of the OS? –  joeqwerty Jul 30 '10 at 1:18
    
Physical is 1GB, available physical is 374000 Nonpaged is 722000 –  Glenn Slaven Jul 30 '10 at 3:03

2 Answers 2

up vote 1 down vote accepted

[SOLVED] Hi guys,

In the event that, like me, somebody else comes across this page trying to find an answer..

I had the exact same problem using Virtual SMTP server on an XP x64 box with 4GB ram and plenty of disk space so I knew it was not a resource issue. I tried adding various directory security settings (including everybody with full control to the Inetpub directory and it's subdirectories).

I was about to wipe and reinstall IIS completely but on a whim I just removed the SMPT server component and reinstalled. It began working again straight away.

Hope this info can help somebody else Moz

share|improve this answer

This error can unfortunately mean that your firewall is open, or you have malware that is sending spam through your SMTP server.

Look at some of the files in your folder C:\Inetpub\mailroot\Queue\ and open them in notepad. If the content of the email looks like junk, and you have thousands upon thousands of messages then this is probably what happened.

Unfortunately for me my dedicated GoDaddy server's dedicated hardware firewall decided to reset itself when the server itself was rebooted and the software they're using is so ancient that port 25 is open by default.

Tip: You may have so many files in this Queue directory that Windows Explorer can't even open the folder. If you suspect this is the issue then go straight to the command line and just issue dir command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.