Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this external harddrive:
_ Buffalo Ministation TurboUSB HD-PS250U2 250 GB
_ just formatted using ext3
_ 250 GB
_ interface USB2
_ SATA 150 internal interface
_ no hardware encryption
_ full specs can be found here: http://www.dooyoo.co.uk/external-hard-drive/buffalo-ministation-turbousb-hd-ps250u2-250-gb/details/

I was doing some data transfer benchmarks using a file foo.tar.bz2 on different machines. I just attached the hard disk to a USB port and copied the file from the computer's hard disk to the external one (using the cp command).

On my development machine (Linux CentOS) the data transfer rate is 33MBps (which is good).

My problem is with our office server. There the data transfer rate is 1MBps! How can it be so low?!

Some details about the office server:
_ Dell PowerEdge T300
_ running CentOS 64-bit
_ running VirtualBox
_ the benchmark was done on the host system, not on a virtual machine _ at the moment I don't think the server is particoularly busy

The output of "/sbin/hdparm -tT /dev/sda1" on my development machine is:
Timing cached reads: 4220 MB in 2.00 seconds = 2108.41 MB/sec
Timing buffered disk reads: 332 MB in 3.02 seconds = 110.10 MB/sec

The output of "/sbin/hdparm -tT /dev/sda1" on the server machine is:
Timing cached reads: 25500 MB in 1.99 seconds = 12795.49 MB/sec
Timing buffered disk reads: 398 MB in 3.01 seconds = 132.04 MB/sec

What do you think can be the problem?

I think there is problably a piece of software missing, maybe a driver or a kernel module.
Or maybe a configuration problem?
Or maybe VirtualBox is causing the problem?
Or maybe the issue is the speed of the machine's internal bus?

Thanks for reading, Daniele

share|improve this question

1 Answer 1

up vote 10 down vote accepted

1 MB/s sounds like USB 1.1 connection instead of USB 2.0. What does dmesg tell you about the USB drive?

Edit: So in this case the real reason was that by default the USB drive got mounted with sync option instead of async. That killed the write performance.

share|improve this answer
    
usb 1-7.2: new high speed USB device using ehci_hcd and address 12 ||||||||||||||| usb 1-7.2: configuration #1 chosen from 1 choice ||||||||||||||| usb-storage: device found at 12 ||||||||||||||| usb-storage: waiting for device to settle before scanning ||||||||||||||| usb-storage: device scan complete –  Daniele Jul 30 '10 at 11:29
2  
Looks like an USB 2.0 connection. Perhaps the disk gets mounted with sync option, that might kill the write performance. Is the reading slow as well? If just writing is slow, try to mount the disk like mount -o async,rw /dev/sda1 /some/mountpoint –  Janne Pikkarainen Jul 30 '10 at 11:40
    
Great Janne. That was it. I had to use the async option while mounting –  Daniele Jul 30 '10 at 12:05
    
Glad to hear that. :) Have a nice weekend! –  Janne Pikkarainen Jul 30 '10 at 12:10
    
Guidance for changing this option for devices automounted by usbmount is given in askubuntu.com/a/500575/237134 –  beldaz Jul 21 at 10:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.