Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to host an ASP.NET 4.0 web application in IIS 6 on Windows 2003 R2 SP2 x64.

Is this even possible? I have the following under C:\WINDOWS\microsoft.net\Framework

  • 1.0.3705
  • 1.1.4322
  • 2.0.50727
  • 3.0
  • 3.5
  • 4.0.30319

and in C:\WINDOWS\microsoft.net\Framework64 the same except 1.0 and 1.1.

IIS 6 runs in 32 bit mode but there is no ASP.NET tab in the properties screen of the website. So I can't switch frameworks and don't know what frameworks runs in what application pool.

EDIT have tried what GregD suggested. That gave me back the tab in IIS so that I could set the proper framework for the website, but it gave me the following in the eventlog when I tried to start the application pool:

Could not load all ISAPI filters for site/service. Therefore startup aborted.

After a quick googling, I found this: http://nishantrana.wordpress.com/2008/09/09/service-unavailable-could-not-load-all-isapi-filters-for-siteservice-therefore-startup-aborted/

Which kind of puts me in a circle. Enabling and removing the 64 bit setting in the metabase.xml file.

Because aspnet_regiis -i told me that it couldn't work because IIS was in a 64-bit setting.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You can do it.

On your web service extensions folder (in IIS Manager) are your asp.net extensions enabled for the different versions?

Edited to add: To get your tab back try this:

1) Stop the IIS Admin service (and any services that depend on it)

2) Open C:\WINDOWS\system32\inetsrv\MetaBase.xml in notepad or your favorite XML Editor. DELETE the line that reads ‘Enable32BitAppOnWin64=”TRUE”’

3) Restart IIS

share|improve this answer
    
yes it's all enabled. but i can't switch frameworks, the tab is not there –  JP Hellemons Jul 30 '10 at 13:48
    
Is this running on VMWare by chance? –  GregD Jul 30 '10 at 13:58
    
Hello GregD, it's not running on VMWare, just a normal win 2003 x64 install. but i cannot switch .net frameworks in iis. –  JP Hellemons Aug 2 '10 at 7:23
    
Editing the MetaBase.xml file worked perfectly for me. Thanks –  AndyMcKenna Aug 10 '10 at 6:58
    
It gave me my option back to select asp.net 4 but then got this in the eventlog: Description: Could not load all ISAPI filters for site/service. Therefore startup aborted. will take a closer look tomorrow :) thanks! –  JP Hellemons Aug 10 '10 at 15:06

It works now. It seems that I can't have the option in IIS to switch frameworks.

I did:

C:\WINDOWS\microsoft.net\Framework\v4.0.30319>cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 True

and then

C:\WINDOWS\microsoft.net\Framework\v4.0.30319>aspnet_regiis.exe -i -enable

and it worked! As I said, no ASP.NET tab is visible in IIS, but it works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.