Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

we have the following config in Cisco 2811:

interface FastEthernet0/1

ip address 10.1.2.1 255.255.255.0 secondary

ip address 10.90.11.1 255.255.255.0 secondary

ip nat inside


(10.90.11.0/24 goes via IPSec to another routers)


ip nat inside source list 101 interface FastEthernet0/0 overload

ip nat inside source list 103 interface FastEthernet0/0 overload

access-list 101 permit ip 10.1.2.0 0.0.0.255 any

access-list 103 deny ip 10.90.11.0 0.0.0.255 10.90.0.0 0.0.255.255

access-list 103 permit ip 10.90.11.0 0.0.0.255 any

everything works. the hosts inside 10.90.11.0/24 and the hosts in 10.90.* networks connected via IPSec can see each others, the remote routers can see this Cisco 2811 as well.

But Cisco can't see any router or a host except a hosts in the local 10.90.11.0/24. Small but annoying problem.

how can I solve this? help plz.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This is most probably because when you try to ping(?), .. remote host from the cisco device the source IP is not 10.90.11.1
If you run a ping, try doing an extended ping to only running "ping" you will be asked for the source internet/ip to use, put 10.90.11.1 and it should work

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.