Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Our domain uses Google Apps for mail and Mailchimp for templated email campaigns. Mailchimp recommends adding an SPF record for their servers to decrease the likelihood of spam filter traps.

I have setup the SPF records below for "v=spf1 ~all" "v=spf1 ~all"

This appears to be the correct setup from what I have read from both vendors. However, when I test the records using, I get "permerror (multiple SPF records). Details are below.

Does anyone have a suggestion how to correct this? I've tried a number of different configurations all with the same result. Most everything I've found focuses on a single SPF record - not multiple.

SPF check: permerror Sender-ID check: permerror

SPF check details:

Result: permerror (multiple SPF records) ID(s) verified: DNS record(s): 3600 IN TXT "v=spf1 ~all" 3600 IN TXT "v=spf1 ~all"

Thanks in advance - Jeff Adkisson

share|improve this question
up vote 2 down vote accepted

you need to include every thing in a single TXT record

share|improve this answer
Thank you... that put me on the right track. Here's what worked: TXT "v=spf1 mx include: ~all" ---------------------------------------------------------- SPF check details: ---------------------------------------------------------- Result: pass ID(s) verified: DNS record(s): 3600 IN TXT "v=spf1 mx include: ~all" – Jeff Jul 31 '10 at 16:27
Why do you have a blank include at the end of the record ? – topdog Aug 1 '10 at 6:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.